#546: Не запускается приложение БИТ.MDT после обновления. Не устанавливается BIT:ERP DataProvider.

Отредактирована: 18 дней назад

Симптомы

  • На мобильном устройстве в Информации об устройстве выбрали Сброс данных, выбрали релиз - приложение зависает, обновление на новый релиз не запускается
  • Если нажать БИТ.MDT, просит удалить BIT:ERP DataProvider, затем установить BIT:ERP DataProvider, и возвращается к этому окну.
  • - Приложение выдает ошибку "Не удалось подключить внешнюю компоненту MobileAdapter" и не пускает дальше
  • - Приложение выдает ошибку "Не удалось подключить внешнюю компоненту AndroidUtils" и не пускает дальше
  • Ошибка инициализации: "Ошибка разбора QR кода настроек подключения"
    fb8cb7d6-2140-4042-bda5-00216e54c910.jpg
  • Панель оператора не хочет обновляться, висит 10 мин
  • Завис ТСД при обновлении приложения.
  • Не запускается МДТ.
  • Панель при обновлении зависает.
  • ТСД завис на стадии обновления, предварительно удалив приложение
  • Как удалить и заново установить приложение БИТ.MDT?
  • Приложение зависает, обновление на новый релиз не запускается
  • Ошибка при обновлении приложения БИТ.МДТ "Ошибка установки install error 4 "INSTALL_FAILED_PACKAGE_CHANCED. Package was removed before install could complete"
  • На тсд постоянно ошибка обновления

Решение

  1. На устройстве удалить приложения БИТ.MDT и BIT:ERP DataProvider.
    • Откройте на устройстве Настройки.
    • Перейдите на вкладку Приложения.
    • Найдите приложение БИТ.MDT (аналогично BIT:ERP DataProvider).
    • Удалите приложение, нажав Удалить.
  2. Если удаление невозможно, очистить данные этого приложения:

  3. Перезапустите устройство
  4. Установите приложение БИТ.MDT (где скачать) или по ссылке (выбирайте "Релиз"! Не "Пререлиз")
  5. Выберите расположение базы:
  6. Введите код инициализации
  7. Если не сработало, Выполните сброс устройства Android к заводским настройкам, и начните с пункта 3.
  8. Если не помогло, напишите на поддержку.

Причина

Ошибки вызваны или тем, что процесс установки не был завершен, или истекла лицензия. После переустановки приложения у вас будет 2 часа, чтобы получить лицензию (на начальном экране после авторизации нажать на кнопку запросить).