#4694: Ошибка: "Конфликт блокировок при выполнении транзакции: Microsoft OLE DB Driver for SQL Server"

Отредактирована: 26 дней назад

Симптомы

  • Долго не проводятся задания на участок.
  • В заказе на эмиссию коды эмитированы.
  • Ошибка в Журнале регистрации:
Ошибка при вызове метода контекста (Выполнить)
{БИТMDT РегистрСведений.битмдт_MarkEvents.МодульМенеджера(1877)}:Возврат Запрос.Выполнить().Выгрузить();
{БИТMDT РегистрСведений.битмдт_MarkEvents.МодульМенеджера(873)}:СуществующиеСобытия = СуществующиеСобытия(EventType, ДанныеСобытий);
{БИТMDT РегистрСведений.ПулКодовМаркировкиСУЗ.МодульМенеджера(2149)}:Не битмдт_НастройкиСистемыПовтИсп.ПередаватьСобытиеЭмиссииНаМобильныеУстройства());
{БИТMDT РегистрСведений.битмдт_ОчередьЭмиссииПоЗаказам.МодульМенеджера(284)}:РегистрыСведений.ПулКодовМаркировкиСУЗ.битмдт_ЗарегистрироватьЭмиссию(
{БИТMDT РегистрСведений.битмдт_ОчередьЭмиссииПоЗаказам.МодульМенеджера(131)}:ОбработкаЗавершена = РегистрыСведений.битмдт_ОчередьЭмиссииПоЗаказам.
{БИТMDT РегистрСведений.битмдт_ОчередьЭмиссииПоЗаказам.МодульМенеджера(93)}:ОбработатьЗаказ(Выборка.ЗаказНаЭмиссию);
{БИТMDT ОбщийМодуль.битмдт_РегламентныеЗадания.Модуль(1050)}:РегистрыСведений.битмдт_ОчередьЭмиссииПоЗаказам.РегламентнаяОбработка(КлючЗадания);
{БИТMDT ОбщийМодуль.битмдт_РегламентныеЗадания.Модуль(247)}:ОбработкаОчередиЭмиссииПоЗаказам(КлючЗадания);
{БИТMDT ОбщийМодуль.битмдт_ИнтеграцияАдаптер.Модуль(470)}:битмдт_РегламентныеЗадания.ВыполнитьРегламентноеЗадание(КлючЗадания);
{БИТMDT ОбщийМодуль.адаптер_РегламентныеЗадания.Модуль(44)}:Модуль.ВыполнитьРегламентноеЗадание(КлючЗадания);
{БИТMDT ОбщийМодуль.ОбменДаннымиСервер.Модуль(19)}:адаптер_РегламентныеЗадания.ВыполнитьРегламентноеЗадание(КодСценарияОбмена);

[ОшибкаВоВремяВыполненияВстроенногоЯзыка]
по причине:
Ошибка выполнения запроса
по причине:
Конфликт блокировок при выполнении транзакции:
Microsoft OLE DB Driver for SQL Server: Превышено время ожидания запроса на блокировку.
HRESULT=80040E31, SQLSrvr: SQLSTATE=HYT00, state=38, Severity=10, native=1222, line=1

Решение

  1. Перезапустите сервер 1С с очисткой кэша по статье.

Причина

Конфликт блокировок при попытке проведения задания, необходимо сбросить зависшие регламентные задания.