#2750: Восстановление обменов при разворачивании базы из бэкапа

Отредактирована: 52 дня назад

Симптомы

Необходима помощь с восстановлением системы, развернули бэкап 2х недельной давности

Восстановил базу из бэкапа верните работоспособность.

Агрегируется КИ в КИ, или КИТУ в КИГУ.

Решение

  1. Устрани дублирование идентификаторов:
    • MarkID: Увеличьте номер MarkID в справочнике (e1cib/list/Справочник.битмдт_НумераторMarkID) на 10 млн, чтобы избежать генерации дубликатов.
    • Коды КИТУ: В настройках MDT увеличьте значение "Цифра расширения для SSCC", чтобы исключить дублирование кодов КИТУ.
    • Нумератор заданий марок: Увеличьте номер в справочнике (e1cib/list/Справочник.битмдт_НумераторЗаданийМарок) на 100 тыс., чтобы новые события назначались заданиям с новыми номерами.
  2. Выгрузи данные с ЕБД или устройств.
  3. Загрузи события в базу 1С по статье.
  4. Создай новый токен, заполни данные в базе клиента, запроси удаление старого по статье.
    • Создай новый снимок для инициализации.
    • Проинициализируй все устройства новым кодом инициализации (обновление со сбросом всех параметров) — это нужно, чтобы устройства начали работать с новым токеном.
  5. Если восстановить марки из БД устройств не удалось:
    • Для отгрузки КИГУ и КИ установите параметр "Проверять владельца марок при отгрузке клиенту" в значение нет.
    • Для отгрузки КИТУ пересоберите новые агрегаты с новым номером КИТУ используй функцию "Принимать неизвестные марки".
  6. Создайте новые задания и работайте по ним. Не используйте распечатанные марки для которых нет заказа на эмиссию в восстановленной базе 1С.
  7. Не используй задания которые есть на устройствах заверши задания и создай новые.

Причина

Потеряли базу, последний доступный бэкап 2х недельной давности